Porównaj ceny domen i usług IT, sprzedawców z całego świata
php

php: "short_open_tag = On" nie działa


Niedawno zainstalowałem Win8 na moim komputerze. Następnie zainstalowałem wamp 2.2 z php 5.4 i nie mogę uruchomić krótkiego tagu.
Ustawiłem już:

"short_open_tag = On"

do pliku php.ini i jestem pewien, że apache ładuje poprawny plik, ponieważ ścieżka do „Loaded Configuration File” w
phpinfo ()
jest dobra.
Chętnie bym doradził. Podziękować.
Zaproszony:
Anonimowy użytkownik

Anonimowy użytkownik

Potwierdzenie od:

Niedawno miałem ten sam problem po aktualizacji z
PHP 5.3.18
do
PHP 5.5.9.
.
Zdałem sobie sprawę, że z jakiegoś powodu
short_open_tag
pojawia się dwukrotnie w moim pliku php.ini.
Jeśli przeprowadziłeś wyszukiwanie, aby dostać się do tej części pliku
php.ini
, spróbuj kontynuować wyszukiwanie, aby sprawdzić, czy jest inna instancja.
Anonimowy użytkownik

Anonimowy użytkownik

Potwierdzenie od:

Zainstalować:
asp_tags = On and short_open_tag = On

w obu \ apache \ Apache2.2.22 \ bin \ php.ini i \ bin \ php \ php5.4 \ php.ini, a następnie zrestartuj serwer Apache.
Jeśli nie masz dostępu do php.ini, możesz spróbować włączyć je za pomocą pliku .htaccess, ale jest możliwe, że firma hostingowa wyłączyła to, jeśli korzystasz z hostingu współdzielonego:
php_value short_open_tag 1

Pamiętaj, aby ponownie uruchomić usługę (apache2 itp.), Aby zmiany w php.ini odniosły skutek.
Anonimowy użytkownik

Anonimowy użytkownik

Potwierdzenie od:

Pamiętaj, aby wymienić wszystkie
short_open_tag

wystąpienia w pliku php.ini.
W moim przypadku było kilka miejsc, w których zostało to zdefiniowane.
U mnie złe ustawienie znajdowało się pod
;;;;;;;;;;;;;;;;;;;;
; Language Options ;
;;;;;;;;;;;;;;;;;;;;
Anonimowy użytkownik

Anonimowy użytkownik

Potwierdzenie od:

Zmień wartość
short_open_tag
na
On
.
Jeśli twój plik
php.ini
znajduje się w
/etc/php/5.6/fpm
, musisz ponownie uruchomić usługę
php5.6-fpm
z
sudo service php5.6-fpm restart

Aby odpowiedzieć na pytania, Zaloguj się lub Zarejestruj się