Porównaj ceny domen i usług IT, sprzedawców z całego świata

Czy łatanie Galera bez aktualizowania MariaDB jest bezpieczne?


Używam MariaDB Galera Cluster od jakiegoś czasu i dopiero dzisiaj zdałem sobie sprawę, że pomimo posiadania identycznych wersji MariaDB na wszystkich węzłach, wszystkie moje wersje wtyczki Galera są różne.
Wydaje się, że to jest powód, dla którego otrzymuję

takie błędy protokołu
https://dba.stackexchange.com/ ... 71-pr
podczas transferu rządowego.
Tylko wersje łat są różne. (w zakresie od 25.3.20 do 25.3.25). Jeszcze bardziej zagmatwane, kiedy biegam
       show global variables like 'wsrep_patch_version';
Otrzymuję „wsrep_25.4” na wszystkich węzłach.
Nic z tego nie rozumiem, ale wygląda na to, że chociaż Galera jest instalowana jako zależność, kiedy

instalacja pakietu MariaDB-server
https://mariadb.com/kb/en/libr ... h-yum, nie aktualizuje też, kiedy

aktualizacja serwera MariaDB
https://mariadb.com/kb/en/libr ... r/... Przynajmniej nie pomniejsze aktualizacje wersji, które zrobiłem.
Obecnie jestem w sytuacji, w której muszę samodzielnie zaktualizować pakiet Galera, aby naprawić te błędy, ale nie czekam na aktualizację MariaDB w ruchliwym czasie.
Pytanie brzmi więc: czy można bezpiecznie zaktualizować pakiet Galera samodzielnie bez aktualizowania samej MariaDB? Innymi słowy, czy Galera 25.3.27 jest kompatybilna z MariaDB 10.2.22? I to prawdopodobnie naprawi moje błędy protokołu?
Zaproszony:
Anonimowy użytkownik

Anonimowy użytkownik

Potwierdzenie od:

Po zaktualizowaniu pakietu "galera" do najnowszej wersji (ale pozostawieniu MariaDB w wersji 10.2.22) wszystko działa dobrze. KST zakończono bez błędów.

Aby odpowiedzieć na pytania, Zaloguj się lub Zarejestruj się