Fedora Core 6: nie można zainstalować programu yum


Jestem nowy w Linuksie, więc próbuję uruchamiać apache i PHP na moich stronach internetowych, a potem zostawiam swój serwer Linux w spokoju i po prostu działa, żadnych skarg.
Jednak tym razem pracuję z VPS Network Solutions i nie ma on żadnych wstępnie zainstalowanych narzędzi, takich jak yum. Próbuję zainstalować te narzędzia, ale problem polega na tym, że wszystkie instrukcje dotyczą różnych dystrybucji Linuksa lub innej wersji FC. Ostatnia instrukcja dotycząca

http://www.wallpaperama.com/fo ... .html
http://www.wallpaperama.com/fo ... .html
- prowadzi do tego błędu.
There was a problem importing one of the Python modules
required to run yum. The error leading to this problem was: No module named yumPlease install a package which provides this module, or
verify that the module is installed correctly.It's possible that the above module doesn't match the
current version of Python, which is:
2.4.3 (#1, Oct 1 2006, 17:59:36)
[GCC 4.1.1 20060928 (Red Hat 4.1.1-28)]

Wszystko było w porządku, dopóki nie dotarłem do linii ./configure - podobno nowa wersja yum nie ma tego katalogu ??
Czy program jest instalowany inaczej dla każdej wersji? Właściwie tylko próbuję zainstalować APC do buforowania PHP, ale wszystko, co przeczytałem, mówi, że yum jest do tego najlepsze ...
Czy ktoś może wskazać mi właściwy kierunek?

Aktualizacja: przeglądam swoje katalogi i widzę/yum.repos.d, jak mam go stamtąd zainstalować?


Plik readme do bzdur mówi: „Uruchom make install”, jeśli jesteś masochistą, co zrobiłem :( Co robi make install w tym przypadku ...

Zaproszony:
Anonimowy użytkownik

Anonimowy użytkownik

Potwierdzenie od:

Naprawdę powinieneś zainstalować go z RPM. Chociaż - to bardzo dziwne dla maszyny FC6, że yum nie jest instalowany domyślnie.
Oto RPM FC6 - możesz spróbować pobrać yum i jego zależności i zainstalować za pomocą rpm -Uvh * .rpm
http://archives.fedoraproject. ... i386/
http://archives.fedoraproject. ... i386/ http://archives.fedoraproject. ... RPMS/
http://archives.fedoraproject. ... RPMS/
Anonimowy użytkownik

Anonimowy użytkownik

Potwierdzenie od:

Zgodnie z opublikowanymi instrukcjami FC6 wymaga yum w wersji 3.0.1
Czy to jest wersja, którą pobrałeś? Jeśli właśnie skopiowałeś i wkleiłeś z pól kodu, prawdopodobnie masz niewłaściwą wersję yum.
Spróbuj zamienić linie podpowiedzi na następujące.
wget [url=http://linux.duke.edu/projects/yum/download/3.0/yum-3.0.1.tar.gz]http://linux.duke.edu/projects ... ar.gz[/url]
tar -xvzf yum-3.0.1.tar.gz
cd yum-3.0.1

W tym folderze nie ma również skryptu konfiguracyjnego. Więc zignoruj ​​wiersz ./configure i przejdź od razu do wykonania.
Według pliku INSTALL nie jest to najlepszy sposób, aby zmusić mniam do pracy, więc powodzenia!

Aby odpowiedzieć na pytania, Zaloguj się lub Zarejestruj się