PCRE nie obsługuje UTF8


Próbuję uruchomić wyrażenie regularne w mojej witrynie i otrzymuję odpowiedź:

Błąd kompilacji: obsługa \ P, \ p i \ X nie została skompilowana z przesunięciem 1

Szukając trochę w Google, odkryłem, że najwyraźniej mój PCRE na moim serwerze nie obsługuje UTF8 i dlatego powoduje problemy. Kiedy używam ssh z pcretest -C, otrzymuję
PCRE version 6.6 06-Feb-2006
Compiled with
UTF-8 support
No Unicode properties support
Newline character is LF
Internal link size = 2
POSIX malloc threshold = 10
Default match limit = 10000000
Default recursion depth limit = 10000000
Match recursion uses stack

Kiedy uruchamiam yum update pcre, pojawia się komunikat, że nie ma nic do aktualizacji.
Ludzie mówią mi, że mogę włączyć obsługę UTF-8 ... pomoc?
Jestem nowicjuszem.
Zaproszony:
Anonimowy użytkownik

Anonimowy użytkownik

Potwierdzenie od:

Odwiedź tę witrynę.
http://gaarai.com/2009/01/31/u ... pcre/
http://gaarai.com/2009/01/31/u ... pcre/
Omawia Twój problem i rozwiązanie.
Mam nadzieję że to pomoże.
David

Aby odpowiedzieć na pytania, Zaloguj się lub Zarejestruj się